Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
HP.com home
Technical documentation

HP-UX Java Patch Information

  »

Java on HP-UX documentation

Content starts here
HP-UX 11.11 patches required for Java™ 6.0 with the June '03 Quality Pack

This list of patches is for Java 6.0 running on HP-UX 11.11 with the June '03 Quality Pack installed.

The table shows the earliest patch, as well as patches that supersede it. The earliest patch or any patch in the superseded list is acceptable to resolve the problem affecting Java. Note that as a result, some required patches may appear as supersedes of other required patches. Icons and headings are explained below.

To download all of the patches shown here, go to the HP Support Center at http://www.hp.com/go/hpsc. (Support contract required). For more information on individual patches, click on the patch name below.

earliest
patch
Arch ratings FuncArea problem description(s)
list of supersedes
PHKL_25468 PA-RISC® patch rating reboot  base improves performance and capacity of i/o polling
PHKL_30542 PHKL_40704
PHKL_25842 PA-RISC® patch rating reboot  base supports Solaris-like semantics for concurrent close (thread termination)
PHKL_30288 PHKL_34311 PHKL_35145
PHKL_28489 PA-RISC® patch rating criticalreboot  base solves kernel trap handler problem causing hang after fork()
(no supersedes)
PHNE_29887 PA-RISC® patch rating criticalreboot  base net solves socket problems that may cause hangs. must install starting with 1.4.2.06, 5.0.
supports Solaris-like semantics for concurrent close (transport)
supports connected datagram sockets
PHNE_31247 PHNE_33159 PHNE_33628 PHNE_34135 PHNE_34672 PHNE_35183
PHNE_35351 PHNE_36125 PHNE_37671 PHNE_37898 PHNE_38678 PHNE_39386
PHNE_42029
PHCO_29960 PA-RISC® patch rating critical  base solves pthread synchronization causing hangs. must install starting with 1.3.1.11, 1.4.1.03, 1.4.2.00, 5.0.
PHCO_30544 PHCO_33282 PHCO_36229 PHCO_38307
PHSS_30049 PA-RISC® patch rating critical  net enables LD_PRELOAD_ONCE
solves problem with dld while loading native libraries for class ServerSocket
PHSS_30966 PHSS_30968 PHSS_30970 PHSS_32864 PHSS_33033 PHSS_33035
PHSS_33037 PHSS_35379 PHSS_35381 PHSS_35383 PHSS_35385 PHSS_37516
PHSS_37517 PHSS_38154 PHSS_39077 PHSS_39749 PHSS_40549 PHSS_41214
PHSS_41713 PHSS_42253 PHSS_42977
PHKL_32927 PA-RISC® patch rating criticalreboot  base fixes 64-bit Java process hang when returning from a call to a JNI function
PHKL_36763
PHKL_34534 PA-RISC® patch rating criticalreboot  base java.lang.Object.notify() may not wakeup a waiter and it may result in an application hang
PHKL_38299 PHKL_38430
PHSS_35385 PA-RISC® patch rating critical  base linker patch, required by Java 6.0 runtime
PHSS_37516 PHSS_37517 PHSS_38154 PHSS_39077 PHSS_39749 PHSS_40549
PHSS_41214 PHSS_41713 PHSS_42253 PHSS_42977
PHKL_39133 PA-RISC® patch rating criticalreboot  base solves socket problems that may cause hangs. must install starting with 1.4.2.06, 5.0.
PHKL_43822
Generated on Mon Oct 13 23:58:57 2014

Legend

Earliest Patch
The earliest patch in the list of superseded patches that solves the problem affecting Java.
Ratings
Patch ratings:
Level 1: Functionally tested by HP to verify that the patch fixes the problem that it purports to fix. No unwanted side effects were discovered. Also, HP has verified that the patch will install and de-install in its target environments. Level 1: Functionally tested by HP to verify that the patch fixes the problem that it purports to fix. No unwanted side effects were discovered. Also, HP has verified that the patch will install and de-install in its target environments.
Level 2: Installed in a certain number of customer environments with no problems reported. Level 2: Installed in a certain number of customer environments with no problems reported.
Level 3: Stress and performance tested by HP in simulated customer mission critical environments using common application stack. Not all patches undergo this testing. Level 3: Stress and performance tested by HP in simulated customer mission critical environments using common application stack. Not all patches undergo this testing.
Fixes critical problem. Fixes critical problem.
Reboot required after installation. Reboot required after installation.
Has special installation instructions. Has special installation instructions.
List of supersedes
The list of patches, if any, that supersede the earliest patch, in order from left to right beginning with the first supersede to the most current. Any patch in the list is acceptable to resolve the problem affecting Java.
FuncArea
The functional area of Java that is affected (fixed) by this patch:
base - Required for basic or core Java features
cap - Recommended for large Java applications (capacity)
gui - Required for Java GUI behavior and performance
net - Required for Java networking API behavior and performance
nfs - Required for execution of Java across NFS
perf - Recommended for best Java performance
tools - Required for HP Java tools (jmeter, jconfig, jtune)
Problem description(s)
Description of why this patch is needed for Java.
Java™ and all Java based trademarks and logos are trademarks or registered trademarks of Oracle America and/or its affiliates in the United States and other countries. Java™ compatible logo
Printable version
Privacy statement Using this site means you accept its terms
© 2014 Hewlett-Packard Development Company, L.P.